[Compo] Arsenal

Répondre
smealum
Rang 2
Rang 2
Messages : 17
Enregistré le : 26 juin 2005 12:46

[Compo] Arsenal

Message par smealum » 31 déc. 2010 23:04

Nom : Arsenal
Auteur(s) : Smealum et lobo
Origine : France

Petite description : un shoot em up en dual 3D. Fait pour être assez difficile, donc un coup dans la gueule et t'es mort. Le jeu comporte un niveau (mais quel niveau !), et un super éditeur de niveaux trop bien. (il faut surement avoir la dernière version de .NET pour le faire tourner)
Pour faire tourner un niveau à vous, il suffit de glisser son dossier dans le dossier shmup/levels que vous aurez préalablement placé à la racine de votre carte. (note : ce dossier n'est nécessaire que pour faire tourner des niveaux customs, le jeu tourne très bien sans sinon)
Les touches : D-PAD pour bouger, R/L pour tirer (on peut tirer manuellement ou rester appuyé pour découvrir les joies de l'autofire), Start pour la pause.

Quelques screenshots :

Image Image Image


Télécharger : http://smealum.net/arsenal/arsenal311210.rar

PS : je comptais faire plus de niveaux, mais mon PC a pas arrêté de BSOD aujourd'hui, donc bon... :/ mais y a l'éditeur de niveaux, alors lachez vous !

Avatar du membre
kukulcan
Modérateur
Modérateur
Messages : 53
Enregistré le : 02 oct. 2006 15:37
Localisation : France
Contact :

Re: [Compo] Arsenal

Message par kukulcan » 03 janv. 2011 15:34

Une vrai tuerie, j'adore :D
Il en est qui n'étreignent que des Ombres, Ceux-là n'ont jamais qu'ombre de bonheur.

smealum
Rang 2
Rang 2
Messages : 17
Enregistré le : 26 juin 2005 12:46

Re: [Compo] Arsenal

Message par smealum » 03 janv. 2011 21:57

Merci kukulcan ! :D
Voici une petite vidéo du jeu : :)
http://www.youtube.com/watch?v=AIYYBFt62nQ

Avatar du membre
beredezebe
Modérateur
Modérateur
Messages : 567
Enregistré le : 05 avr. 2010 17:07

Re: [Compo] Arsenal

Message par beredezebe » 11 janv. 2011 19:40

Quand je lance le jeu sur une Supercard DSTWO, j'obtiens cette erreur :



Guru Mediation Error!
undefined instruction!

pc: 00000020 addr: 00000020

r0:00000001 r8 : 00000000
r1: 00000000 r9 : 00000000
r2: 00000000 r10: 00000000
r3: 00000000 r11: 00000000
r4: 00000000 r12: 04000000
r5: 00000000 sp : 0B0005C8
r6: 00000000 lr : 0201488F
r7: 00000000 pc : 00000024

0B0005C8: 00000000 00000000
0B0005D0: 00000000 00000000
0B0005D8: 00000000 00000000
0B0005E0: 00000000 00000000
0B0005E8: 00000000 00000000
0B0005F0: 00000000 00000000
0B0005F8: 00000000 00000000
0B000600: 00000000 00000000
0B000608: 00000000 00000000
0B000610: 00000000 00000000
Qu'est-ce que cela signifie ? J'aimerais tout de même voir à quoi ça ressemble, parce que beaucoup disent du bien de ton jeu...

smealum
Rang 2
Rang 2
Messages : 17
Enregistré le : 26 juin 2005 12:46

Re: [Compo] Arsenal

Message par smealum » 11 janv. 2011 20:09

beredezebe a écrit :Quand je lance le jeu sur une Supercard DSTWO, j'obtiens cette erreur :



Guru Mediation Error!
undefined instruction!

pc: 00000020 addr: 00000020

r0:00000001 r8 : 00000000
r1: 00000000 r9 : 00000000
r2: 00000000 r10: 00000000
r3: 00000000 r11: 00000000
r4: 00000000 r12: 04000000
r5: 00000000 sp : 0B0005C8
r6: 00000000 lr : 0201488F
r7: 00000000 pc : 00000024

0B0005C8: 00000000 00000000
0B0005D0: 00000000 00000000
0B0005D8: 00000000 00000000
0B0005E0: 00000000 00000000
0B0005E8: 00000000 00000000
0B0005F0: 00000000 00000000
0B0005F8: 00000000 00000000
0B000600: 00000000 00000000
0B000608: 00000000 00000000
0B000610: 00000000 00000000
Qu'est-ce que cela signifie ? J'aimerais tout de même voir à quoi ça ressemble, parce que beaucoup disent du bien de ton jeu...
Merci d'avoir recopié tout le message d'erreur, même, si c'était pas nécessaire. ^^'
Quelqu'un sur gbatemp a eu la même problème, et pourtant EvilTroopa et ludo6431 sur #dev-fr ont aussi testé sur un DSTwo et n'ont rencontré aucun problème.
Tu as bien la dernière version ? ludo m'a confirmé que ça marche sans problème sur la 1.04 et la 1.08. Et apparemment, pour vérifier la version faut aller dans "DS_GAME->start->help".

Consodreams
Rang 3
Rang 3
Messages : 22
Enregistré le : 21 sept. 2010 19:51
Contact :

Re: [Compo] Arsenal

Message par Consodreams » 11 janv. 2011 23:30

Chez nous pas de problèmes, le jeux fonctionne sur DStwo avec une DSI xl.
Je penche aussi pour une mise à jour du kernel.

Avatar du membre
kukulcan
Modérateur
Modérateur
Messages : 53
Enregistré le : 02 oct. 2006 15:37
Localisation : France
Contact :

Re: [Compo] Arsenal

Message par kukulcan » 12 janv. 2011 9:54

Ce jeu me rappel un jeu d'arcarde "Nebulasray © 1994 Namco.", est ce que tu t'en est inspiré Smealum ?
Il en est qui n'étreignent que des Ombres, Ceux-là n'ont jamais qu'ombre de bonheur.

Avatar du membre
beredezebe
Modérateur
Modérateur
Messages : 567
Enregistré le : 05 avr. 2010 17:07

Re: [Compo] Arsenal

Message par beredezebe » 12 janv. 2011 13:10

Firmware 1.08, le jeu ne fonctionne toujours pas quand je le lance avec HBMenu... Je ne vois pas où est le problème...

smealum
Rang 2
Rang 2
Messages : 17
Enregistré le : 26 juin 2005 12:46

Re: [Compo] Arsenal

Message par smealum » 12 janv. 2011 15:17

beredezebe a écrit :Firmware 1.08, le jeu ne fonctionne toujours pas quand je le lance avec HBMenu... Je ne vois pas où est le problème...
C'est peut être con comme question, mais sans HBmenu ça marche ? le jeu utilise EFS, donc n'en a pas besoin.
Si ça marche pas même sans ben je sais pas, c'est bizarre. :/
kukulcan a écrit :Ce jeu me rappel un jeu d'arcarde "Nebulasray © 1994 Namco.", est ce que tu t'en est inspiré Smealum ?
Nan, je connaissais pas, tu viens de me le faire découvrir. ^^

Edit : ludo vient de tester sur DSTwo via hbmenu et ça marche pour lui, donc ça vient probablement pas de là... mais autant tester, ça coûte rien. ^^'
Et si ça marche toujours pas, tu peux essayer de retélécharger le jeu !

Avatar du membre
beredezebe
Modérateur
Modérateur
Messages : 567
Enregistré le : 05 avr. 2010 17:07

Re: [Compo] Arsenal

Message par beredezebe » 12 janv. 2011 15:33

Bien sûr que ça marche pas sans, je l'ai testé normalement à la base...
Mais en tapant "Arsenal" sur GBAtemp, je trouve également ceci. Donc je ne suis pas le seul à obtenir cette erreur, d'autant plus sur Supercard DSTWO.

smealum
Rang 2
Rang 2
Messages : 17
Enregistré le : 26 juin 2005 12:46

Re: [Compo] Arsenal

Message par smealum » 12 janv. 2011 16:15

beredezebe a écrit :Bien sûr que ça marche pas sans, je l'ai testé normalement à la base...
Mais en tapant "Arsenal" sur GBAtemp, je trouve également ceci. Donc je ne suis pas le seul à obtenir cette erreur, d'autant plus sur Supercard DSTWO.
Oui je m'en doutais, mais on sait jamais ! :P
Et ouai je suis au courant que t'es pas le seul, c'est pour ça que je pense pas que ça vienne juste de ta console ou quelque chose comme ça. Mais en même temps, y a 2 autres personnes pour qui ça marche sur le DStwo, donc j'ai du mal à voir le problème.
Dernière tentative, est ce que tu pourrais tester ça : http://smealum.net/arsenal/alpha/gurutest.nds ?
Là du coup, si tu as un guru meditation error, j'aimerais que tu me recopies les adresses derrière : pc et addr. Et si tu pouvais tester plusieurs fois pour être sûr que c'est toujours les mêmes, ce serait encore mieux.
Et si ça marche (j'en doute, mais on sait jamais), bah faut pas oublier que c'est pas la version de la compo et que le framerate risque de souffrir (entre autres) !

Avatar du membre
beredezebe
Modérateur
Modérateur
Messages : 567
Enregistré le : 05 avr. 2010 17:07

Re: [Compo] Arsenal

Message par beredezebe » 12 janv. 2011 17:30

Bon, cette fois-ci, j'obtiens pour pc et addr :

pc: 00000024 addr: 00000024

smealum
Rang 2
Rang 2
Messages : 17
Enregistré le : 26 juin 2005 12:46

Re: [Compo] Arsenal

Message par smealum » 12 janv. 2011 19:24

beredezebe a écrit :Bon, cette fois-ci, j'obtiens pour pc et addr :

pc: 00000024 addr: 00000024
Hm... et en lr, tu as toujours 0201488F ?

Avatar du membre
beredezebe
Modérateur
Modérateur
Messages : 567
Enregistré le : 05 avr. 2010 17:07

Re: [Compo] Arsenal

Message par beredezebe » 14 janv. 2011 17:49

smealum a écrit :Hm... et en lr, tu as toujours 0201488F ?
Pas exactement, cette fois-ci, j'ai :

lr : 02014D81

smealum
Rang 2
Rang 2
Messages : 17
Enregistré le : 26 juin 2005 12:46

Re: [Compo] Arsenal

Message par smealum » 14 janv. 2011 20:30

Merci, toutes les adresses lr qu'on m'a donné jusqu'ici pointent vers la gestion des dossiers de libfat... et toujours à des endroits différents, donc je sais pas trop quoi penser.
Par contre, j'ai demandé à deux autres personnes de tester sur un DStwo, et ça marche sans problème pour eux.
En plus de ça, la personne de gbatemp qui avait le même problème que toi a réussi à la faire marcher. Apparemment, le souci venait de sa micro SD. Il l'a formaté (avec un full format, un quick format marchait pas), remis tous ses fichiers sur sa carte et hop, plus de problème.
Donc si tu pouvais tester avec une autre micro SD ce serait cool. :) Ou alors formater, mais bon, je comprends que ça te fasse chier. ^^'
Bref, le problème viendrait pas d'arsenal lui même, plutot de la libfat ou efs... c'est quand même très bizarre parce que j'imagine qu'arsenal est le seul homebrew qui te donne ce genre de problème, et c'est une assez grosse coïncidence que vous ayiez tous les deux eu des problèmes avec un DStwo...

Répondre

Retourner vers « JEUX / GAMES »